比较来自世界各地的卖家的域名和 IT 服务价格
php

php: "short_open_tag = On" 不起作用

我最近安装过 Win8 在你的电脑。 然后我安装了 wamp 2.2 从 php 5.4, 而且我无法获得短暂的标签来工作。

我已经设置了:

"short_open_tag = On"

到文件。 php.ini, 而且我相信 apache 加载正确的文件,因为路径 "Loaded Configuration File" 在
phpinfo//

好的。

我很高兴有任何建议。 谢。
已邀请:

风见雨下

赞同来自:

我最近在更新后有同样的问题
PHP 5.3.18


PHP 5.5.9.

.

我意识到出于某种原因
short_open_tag

出现在我的文件中 php.ini 两次。

如果您已搜索到文件的这一部分
php.ini

, 尝试继续搜索以查看是否有另一个实例。

莫问

赞同来自:

安装 :


asp_tags = On and short_open_tag = On


在两个文件中 \apache\Apache2.2.22\bin\php.ini 和 \bin\php\php5.4\php.ini, 然后重新启动服务器 apache.

如果您无法访问 php.ini, 您可以尝试通过文件启用它们。 .htaccess, 但如果您在公共托管中,托管公司可能会关闭此操作:


php_value short_open_tag 1


不要忘记重新启动您的服务 /apache2 等等。/, 改变B. php.ini 生效。

八刀丁二

赞同来自:

一定要更换一切


short_open_tag


输入文件 php.ini.
在我的情况下,有几个地方被定义。
对我来说,错误的设置位于下面


;;;;;;;;;;;;;;;;;;;;
; Language Options ;
;;;;;;;;;;;;;;;;;;;;

涵秋

赞同来自:

改变价值
short_open_tag


On

.

如果你的文件
php.ini

位于
/etc/php/5.6/fpm

, 您需要重新启动服务
php5.6-fpm

通过


sudo service php5.6-fpm restart

要回复问题请先登录注册